Jostle's platform is currently unavailable

Incident Report for Jostle AP Status

Resolved

Jostle's platform is available again.
Posted Jul 09, 2024 - 07:52 AEST

Investigating

We are currently investigating and will update status when information is available.
Posted Jul 09, 2024 - 07:51 AEST